PhotoPlog

Go Back   PhotoPlog > PhotoPlog Lite > Bugs & Issues Tracker
Screens Demo Purchase Download Register

Reply
Attention: Last reply in this thread was more than 11 Years ago
 
Thread Tools
  #11  
Old 01-29-2006, 07:53 PM
Morgan's Avatar
Morgan Morgan is offline
Head Plog
Admin
 
Join Date: Dec 2005
Posts: 5,324
Gallery: 10
Comments: 25
Default

Thanks for the info.

I'm thinking that the photoplog_absolute_links function should probably be restricted to the vB headinclude, header, navbar, and footer templates, and there should be some new settings in PhotoPlog.

The forum links obviously need to point to the forum, the PhotoPlog links should already be pointing to PhotoPlog unless I missed something, and there likely needs to be something more in play for other links.

Then there are other styles and such like you mentioned. The photoplog_absolute_links function didn't quite turn out as I had hoped, but that's okay. Good to have a lite version out there and get feedback.
__________________
Please use the forums for support, feature requests, and similar such things. Support does not include custom code, custom template edits, or third-party modifications. PMs and emails to me should be for private information only, such as login information. If you PM or email me a support question, chances are good that I'll ignore it. Thanks.
While the work or play is on, it is a lot of fun if while you are doing one you don't constantly feel that you ought to be doing the other. -- Franklin Pierce Adams
Reply With Quote
  #12  
Old 01-30-2006, 04:49 PM
Nitro Nitro is offline
Yellow Plog
 
Join Date: Dec 2005
Posts: 63
Gallery: 0
Comments: 0
Default

Photoplog links appeared to be all in order, Im pretty sure I used them all viewing, upload, and comment, inc the prev - next mod. Probably didnt give edit a go was all.
Reply With Quote
  #13  
Old 02-17-2006, 01:17 AM
Morgan's Avatar
Morgan Morgan is offline
Head Plog
Admin
 
Join Date: Dec 2005
Posts: 5,324
Gallery: 10
Comments: 25
Default

FYI: the way relative and absolute links are handled has been changed in PhotoPlog Lite v.1.0.7. While the old photoplog_absolute_links function was meant to remove the manual setting of links, it didn't work out as planned.

Why was it changed? There are just too many different ways to consider (e.g., skins, CMS, mods, etcetera) where an automatic linking function, like the old photoplog_absolute_links function, ran into problems (e.g., linking to the wrong location, duplicate directory issues, subdomains, etcetera).

PhotoPlog Lite v.1.0.7 has been coded so you set what and where to link. Granted it's sort of a PITA to do it the first time, but it'll be remembered once you do it, and it should prove to be a more flexible solution, in that you shouldn't need to edit code or templates in order to get absolute links.
__________________
Please use the forums for support, feature requests, and similar such things. Support does not include custom code, custom template edits, or third-party modifications. PMs and emails to me should be for private information only, such as login information. If you PM or email me a support question, chances are good that I'll ignore it. Thanks.
While the work or play is on, it is a lot of fun if while you are doing one you don't constantly feel that you ought to be doing the other. -- Franklin Pierce Adams
Reply With Quote
Reply

« Previous Thread | Next Thread »
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[Closed via Lite v.1.0.7] A small bug in Photoplog Lite alpha Bugs & Issues Tracker 4 02-17-2006 02:24 AM


All times are GMT. The time now is 12:16 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.